The mt-check.cgi script provides you with information about your system's configuration and determines whether you have all of the components you need to run Movable Type.

System Information

Checking for Required Modules

CGI

Your server has CGI installed (version 4.40).

Image::Size

Image::Size is required for file uploads (to determine the size of uploaded images in many different formats).

Your server does not have Image::Size installed, or Image::Size requires another module that is not installed. Please consult the installation instructions for help in installing Image::Size. Details

Can't locate Image/Size.pm in @INC (you may need to install the Image::Size module) (@INC contains: /var/www/test_dir/perl/extlib /var/www/test_dir/perl/lib /usr/lib/perl5/5.28/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.28/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.28/core_perl /usr/share/perl5/core_perl) at (eval 7) line 1. BEGIN failed--compilation aborted at (eval 7) line 1.

File::Spec (version >= 0.8)

Your server has File::Spec installed (version 3.74).

CGI::Cookie

Your server has CGI::Cookie installed (version 4.40).

LWP::UserAgent

LWP::UserAgent is required for creating Movable Type configuration files using the installation wizard.

Your server does not have LWP::UserAgent installed, or LWP::UserAgent requires another module that is not installed. Please consult the installation instructions for help in installing LWP::UserAgent. Details

Can't locate LWP/UserAgent.pm in @INC (you may need to install the LWP::UserAgent module) (@INC contains: /var/www/test_dir/perl/extlib /var/www/test_dir/perl/lib /usr/lib/perl5/5.28/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.28/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.28/core_perl /usr/share/perl5/core_perl) at (eval 10) line 1. BEGIN failed--compilation aborted at (eval 10) line 1.

Scalar::Util

Your server has Scalar::Util installed (version 1.5).

Checking for Data Storage Modules

The following modules are required by databases that can be used with Movable Type. Your server must have DBI and at least one of these related modules installed for the application to work properly.

DBI (version >= 1.21)

Your server has DBI installed (version 1.642).

DBD::mysql

Your server has DBD::mysql installed (version 4.048).

DBD::Pg (version >= 1.32)

Your server has DBD::Pg installed (version 3.7.4).

DBD::SQLite

Your server has DBD::SQLite installed (version 1.60).

DBD::SQLite2

DBI and DBD::SQLite2 are required if you want to use the SQLite 2.x database backend.

Your server does not have DBD::SQLite2 installed, or DBD::SQLite2 requires another module that is not installed. Please consult the installation instructions for help in installing DBD::SQLite2. Details

Can't locate DBD/SQLite2.pm in @INC (you may need to install the DBD::SQLite2 module) (@INC contains: /var/www/test_dir/perl/extlib /var/www/test_dir/perl/lib /usr/lib/perl5/5.28/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.28/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.28/core_perl /usr/share/perl5/core_perl) at (eval 19) line 1. BEGIN failed--compilation aborted at (eval 19) line 1.

Checking for Optional Modules

The following modules are optional. If your server does not have these modules installed, you only need to install them if you require the functionality that they provide.

Digest::SHA

Your server has Digest::SHA installed (version 6.01).

Plack

This module and its dependencies are required in order to operate Movable Type under psgi.

Your server does not have Plack installed, or Plack requires another module that is not installed. Please consult the installation instructions for help in installing Plack. Details

Can't locate Plack.pm in @INC (you may need to install the Plack module) (@INC contains: /var/www/test_dir/perl/extlib /var/www/test_dir/perl/lib /usr/lib/perl5/5.28/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.28/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.28/core_perl /usr/share/perl5/core_perl) at (eval 21) line 1. BEGIN failed--compilation aborted at (eval 21) line 1.

CGI::PSGI

This module and its dependencies are required to run Movable Type under psgi.

Your server does not have CGI::PSGI installed, or CGI::PSGI requires another module that is not installed. Please consult the installation instructions for help in installing CGI::PSGI. Details

Can't locate CGI/PSGI.pm in @INC (you may need to install the CGI::PSGI module) (@INC contains: /var/www/test_dir/perl/extlib /var/www/test_dir/perl/lib /usr/lib/perl5/5.28/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.28/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.28/core_perl /usr/share/perl5/core_perl) at (eval 22) line 1. BEGIN failed--compilation aborted at (eval 22) line 1.

CGI::Parse::PSGI

This module and its dependencies are required to run Movable Type under psgi.

Your server does not have CGI::Parse::PSGI installed, or CGI::Parse::PSGI requires another module that is not installed. Please consult the installation instructions for help in installing CGI::Parse::PSGI. Details

Can't locate CGI/Parse/PSGI.pm in @INC (you may need to install the CGI::Parse::PSGI module) (@INC contains: /var/www/test_dir/perl/extlib /var/www/test_dir/perl/lib /usr/lib/perl5/5.28/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.28/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.28/core_perl /usr/share/perl5/core_perl) at (eval 23) line 1. BEGIN failed--compilation aborted at (eval 23) line 1.

XMLRPC::Transport::HTTP::Plack

This module and its dependencies are required to run Movable Type under psgi.

Your server does not have XMLRPC::Transport::HTTP::Plack installed, or XMLRPC::Transport::HTTP::Plack requires another module that is not installed. Please consult the installation instructions for help in installing XMLRPC::Transport::HTTP::Plack. Details

Can't locate XMLRPC/Transport/HTTP/Plack.pm in @INC (you may need to install the XMLRPC::Transport::HTTP::Plack module) (@INC contains: /var/www/test_dir/perl/extlib /var/www/test_dir/perl/lib /usr/lib/perl5/5.28/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.28/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.28/core_perl /usr/share/perl5/core_perl) at (eval 24) line 1. BEGIN failed--compilation aborted at (eval 24) line 1.

HTML::Entities

Your server has HTML::Entities installed (version 3.69).

HTML::Parser

Your server has HTML::Parser installed (version 3.72).

SOAP::Lite (version >= 0.5)

SOAP::Lite is optional; It is needed if you want to use the MT XML-RPC server implementation.

Either your server does not have SOAP::Lite installed, the version that is installed is too old, or SOAP::Lite requires another module that is not installed. Please consult the installation instructions for help in installing SOAP::Lite. Details

Can't locate SOAP/Lite.pm in @INC (you may need to install the SOAP::Lite module) (@INC contains: /var/www/test_dir/perl/extlib /var/www/test_dir/perl/lib /usr/lib/perl5/5.28/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.28/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.28/core_perl /usr/share/perl5/core_perl) at (eval 27) line 1. BEGIN failed--compilation aborted at (eval 27) line 1.

File::Temp

Your server has File::Temp installed (version 0.2304).

List::Util

Your server has List::Util installed (version 1.5).

Image::Magick

Your server has Image::Magick installed (version unknown).

GD

Your server has GD installed (version 2.69).

Imager

Imager is optional; It is one of the image processors that you can use to create thumbnails of uploaded images.

Your server does not have Imager installed, or Imager requires another module that is not installed. Please consult the installation instructions for help in installing Imager. Details

Can't locate Imager.pm in @INC (you may need to install the Imager module) (@INC contains: /var/www/test_dir/perl/extlib /var/www/test_dir/perl/lib /usr/lib/perl5/5.28/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.28/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.28/core_perl /usr/share/perl5/core_perl) at (eval 37) line 1. BEGIN failed--compilation aborted at (eval 37) line 1.

IPC::Run

IPC::Run is optional; It is needed if you would like to use NetPBM as the image processor for Movable Type.

Your server does not have IPC::Run installed, or IPC::Run requires another module that is not installed. Please consult the installation instructions for help in installing IPC::Run. Details

Can't locate IPC/Run.pm in @INC (you may need to install the IPC::Run module) (@INC contains: /var/www/test_dir/perl/extlib /var/www/test_dir/perl/lib /usr/lib/perl5/5.28/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.28/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.28/core_perl /usr/share/perl5/core_perl) at (eval 38) line 1. BEGIN failed--compilation aborted at (eval 38) line 1.

Storable

Your server has Storable installed (version 3.08).

Crypt::DSA

Crypt::DSA is optional; If it is installed, comment registration sign-ins will be accelerated.

Your server does not have Crypt::DSA installed, or Crypt::DSA requires another module that is not installed. Please consult the installation instructions for help in installing Crypt::DSA. Details

Can't locate Crypt/DSA.pm in @INC (you may need to install the Crypt::DSA module) (@INC contains: /var/www/test_dir/perl/extlib /var/www/test_dir/perl/lib /usr/lib/perl5/5.28/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.28/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.28/core_perl /usr/share/perl5/core_perl) at (eval 40) line 1. BEGIN failed--compilation aborted at (eval 40) line 1.

Crypt::SSLeay

This module and its dependencies are required to permit commenters to authenticate via OpenID providers such as AOL and Yahoo! that require SSL support. Also this module is required for Google Analytics site statistics.

Your server does not have Crypt::SSLeay installed, or Crypt::SSLeay requires another module that is not installed. Please consult the installation instructions for help in installing Crypt::SSLeay. Details

Can't locate Crypt/SSLeay.pm in @INC (you may need to install the Crypt::SSLeay module) (@INC contains: /var/www/test_dir/perl/extlib /var/www/test_dir/perl/lib /usr/lib/perl5/5.28/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.28/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.28/core_perl /usr/share/perl5/core_perl) at (eval 41) line 1. BEGIN failed--compilation aborted at (eval 41) line 1.

Cache::File

Cache::File is required if you would like to be able to allow commenters to authenticate via OpenID using Yahoo! Japan.

Your server does not have Cache::File installed, or Cache::File requires another module that is not installed. Please consult the installation instructions for help in installing Cache::File. Details

Can't locate Cache/File.pm in @INC (you may need to install the Cache::File module) (@INC contains: /var/www/test_dir/perl/extlib /var/www/test_dir/perl/lib /usr/lib/perl5/5.28/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.28/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.28/core_perl /usr/share/perl5/core_perl) at (eval 42) line 1. BEGIN failed--compilation aborted at (eval 42) line 1.

MIME::Base64

Your server has MIME::Base64 installed (version 3.15).

XML::Atom

XML::Atom is required in order to use the Atom API.

Your server does not have XML::Atom installed, or XML::Atom requires another module that is not installed. Please consult the installation instructions for help in installing XML::Atom. Details

Can't locate XML/Atom.pm in @INC (you may need to install the XML::Atom module) (@INC contains: /var/www/test_dir/perl/extlib /var/www/test_dir/perl/lib /usr/lib/perl5/5.28/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.28/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.28/core_perl /usr/share/perl5/core_perl) at (eval 44) line 1. BEGIN failed--compilation aborted at (eval 44) line 1.

Cache::Memcached

Your server has Cache::Memcached installed (version 1.30).

Archive::Tar

Your server has Archive::Tar installed (version 2.30).

IO::Compress::Gzip

Your server has IO::Compress::Gzip installed (version 2.074).

IO::Uncompress::Gunzip

Your server has IO::Uncompress::Gunzip installed (version 2.074).

Archive::Zip

Your server has Archive::Zip installed (version 1.64).

XML::SAX

Your server has XML::SAX installed (version 1.00).

Digest::SHA1

Digest::SHA1 and its dependencies are required in order to allow commenters to be authenticated by OpenID providers including LiveJournal.

Your server does not have Digest::SHA1 installed, or Digest::SHA1 requires another module that is not installed. Please consult the installation instructions for help in installing Digest::SHA1. Details

Can't locate Digest/SHA1.pm in @INC (you may need to install the Digest::SHA1 module) (@INC contains: /var/www/test_dir/perl/extlib /var/www/test_dir/perl/lib /usr/lib/perl5/5.28/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.28/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.28/core_perl /usr/share/perl5/core_perl) at (eval 62) line 1. BEGIN failed--compilation aborted at (eval 62) line 1.

Net::SMTP

Your server has Net::SMTP installed (version 3.11).

Authen::SASL

This module and its dependencies are required in order to support CRAM-MD5, DIGEST-MD5 or LOGIN SASL mechanisms.

Your server does not have Authen::SASL installed, or Authen::SASL requires another module that is not installed. Please consult the installation instructions for help in installing Authen::SASL. Details

Can't locate Authen/SASL.pm in @INC (you may need to install the Authen::SASL module) (@INC contains: /var/www/test_dir/perl/extlib /var/www/test_dir/perl/lib /usr/lib/perl5/5.28/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.28/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.28/core_perl /usr/share/perl5/core_perl) at (eval 66) line 1. BEGIN failed--compilation aborted at (eval 66) line 1.

IO::Socket::SSL

IO::Socket::SSL is required in all of the SSL/TLS connection, such as Google Analytics site statistics or SMTP Auth over SSL/TLS.

Your server does not have IO::Socket::SSL installed, or IO::Socket::SSL requires another module that is not installed. Please consult the installation instructions for help in installing IO::Socket::SSL. Details

Can't locate IO/Socket/SSL.pm in @INC (you may need to install the IO::Socket::SSL module) (@INC contains: /var/www/test_dir/perl/extlib /var/www/test_dir/perl/lib /usr/lib/perl5/5.28/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.28/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.28/core_perl /usr/share/perl5/core_perl) at (eval 67) line 1. BEGIN failed--compilation aborted at (eval 67) line 1.

Net::SSLeay

Net::SSLeay is required to use SMTP Auth over an SSL connection, or to use it with a STARTTLS command.

Your server does not have Net::SSLeay installed, or Net::SSLeay requires another module that is not installed. Please consult the installation instructions for help in installing Net::SSLeay. Details

Can't locate Net/SSLeay.pm in @INC (you may need to install the Net::SSLeay module) (@INC contains: /var/www/test_dir/perl/extlib /var/www/test_dir/perl/lib /usr/lib/perl5/5.28/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.28/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.28/core_perl /usr/share/perl5/core_perl) at (eval 68) line 1. BEGIN failed--compilation aborted at (eval 68) line 1.

Safe

Your server has Safe installed (version 2.40).

Digest::MD5

Your server has Digest::MD5 installed (version 2.55).

Text::Balanced

Your server has Text::Balanced installed (version 2.03).

XML::Parser

Your server has XML::Parser installed (version 2.44).

XML::SAX::ExpatXS (version >= 1.3)

XML::SAX::ExpatXS is optional; It is one of the modules required to restore a backup created in a backup/restore operation

Either your server does not have XML::SAX::ExpatXS installed, the version that is installed is too old, or XML::SAX::ExpatXS requires another module that is not installed. Please consult the installation instructions for help in installing XML::SAX::ExpatXS. Details

Can't locate XML/SAX/ExpatXS.pm in @INC (you may need to install the XML::SAX::ExpatXS module) (@INC contains: /var/www/test_dir/perl/extlib /var/www/test_dir/perl/lib /usr/lib/perl5/5.28/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.28/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.28/core_perl /usr/share/perl5/core_perl) at (eval 75) line 1. BEGIN failed--compilation aborted at (eval 75) line 1.

XML::SAX::Expat (version >= 0.37)

Your server has XML::SAX::Expat installed (version 0.51).

XML::LibXML::SAX (version >= 1.7)

XML::LibXML::SAX is optional; It is one of the modules required to restore a backup created in a backup/restore operation

Either your server does not have XML::LibXML::SAX installed, the version that is installed is too old, or XML::LibXML::SAX requires another module that is not installed. Please consult the installation instructions for help in installing XML::LibXML::SAX. Details

Can't locate XML/LibXML/SAX.pm in @INC (you may need to install the XML::LibXML::SAX module) (@INC contains: /var/www/test_dir/perl/extlib /var/www/test_dir/perl/lib /usr/lib/perl5/5.28/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.28/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.28/core_perl /usr/share/perl5/core_perl) at (eval 77) line 1. BEGIN failed--compilation aborted at (eval 77) line 1.

Mozilla::CA

This module is required for Google Analytics site statistics and for verification of SSL certificates.

Your server does not have Mozilla::CA installed, or Mozilla::CA requires another module that is not installed. Please consult the installation instructions for help in installing Mozilla::CA. Details

Can't locate Mozilla/CA.pm in @INC (you may need to install the Mozilla::CA module) (@INC contains: /var/www/test_dir/perl/extlib /var/www/test_dir/perl/lib /usr/lib/perl5/5.28/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.28/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.28/core_perl /usr/share/perl5/core_perl) at (eval 78) line 1. BEGIN failed--compilation aborted at (eval 78) line 1.

Time::HiRes

Your server has Time::HiRes installed (version 1.9759).

YAML::Syck

Your server has YAML::Syck installed (version 1.31).